disk-usage/PKGBUILD

35 lines
654 B
Bash

# Maintainer: Sam Hadow
_pkgname=disk-usage
pkgname=du-rust
pkgver=0.1.1
pkgrel=1
pkgdesc="Disk usage tool in rust."
arch=('x86_64')
url='https://git.hadow.fr/sam.hadow/disk-usage'
license=('BSD-3-Clause-Attribution ')
makedepends=(cargo git make upx)
provides=("${pkgname}")
conflicts=("${pkgname}")
commit='3227a57848c2ed77331a245d7185522c6ce186ba'
sha256sums=('SKIP')
source=("git+$url#commit=$commit")
prepare() {
cd $_pkgname
}
build() {
cd $_pkgname
export RUSTUP_TOOLCHAIN=stable
export CARGO_TARGET_DIR=target
make build
}
package() {
cd $_pkgname
install -vDm755 target/release/$pkgname -t "$pkgdir/usr/bin/"
}